DOYENSYS Knowledge Portal




We Welcome you to visit our DOYENSYS KNOWLEDGE PORTAL : Doyensys Knowledge Portal




Tuesday, May 31, 2016

REP-51019 system user authentication is missing in oracle reports 12c

REP-51019 system user authentication is missing

1)  In  rwservlet.properties confirm SSO is already disabled:
<singlesignon>no</singlesignon>


2) Disable JAZN security.  In rwserver.conf that belongs to the reports server you will use (in-process, standalone or both) change the following entry:
...
<security class="oracle.reports.server.RWJAZNSecurity" id="rwJaznSec"/>
...
<job jobType="report" engineId="rwEng" securityId="rwJaznSec"/>
...

Add "!--" at the beginning and "--" at the end, in order oracle.reports.server.RWJAZNSecurity is commented:

<!--security class="oracle.reports.server.RWJAZNSecurity" id="rwJaznSec"/-->

and delete securityId="rwJaznSec" in jobType="report":

<job jobType="report" engineId="rwEng"/>

Old Value:

<job jobType="report" engineId="rwEng" securityId="rwJaznSec"/>

New Value:

<job jobType="report" engineId="rwEng"/>

3) Restart the reports server to apply the changes.

 If it was the in-process reports server, or you applied changes in rwservlet.properties, you need to restart WLS_REPORTS.


1 comment:

Sridevi K said...


Regards
Sridevi Koduru (Senior Oracle Apps Trainer Oracleappstechnical.com)
LinkedIn profile - https://in.linkedin.com/in/sridevi-koduru-9b876a8b
Please Contact for One to One Online Training on Oracle Apps Technical, Financials, SCM, SQL, PL/SQL, D2K at training@oracleappstechnical.com | +91 - 9581017828.