DOYENSYS Knowledge Portal




We Welcome you to visit our DOYENSYS KNOWLEDGE PORTAL : Doyensys Knowledge Portal




Thursday, December 29, 2016


Oracle WebLogic Server does not start after domain creation


after installation of WebLogic binaries and creation of the simplest domain configuration (only with Admin Server) from scratch, during the attempt of the first launch of AdminServer it does not start after domain creation and it throws the following error exception: «A failure occurred attempting to load LDIF for provider…».

See bellow the log:
####<Mar 19, 2015 5:19:19 PM MSK> <Error>
<Security> <Unknown> <AdminServer> <[ACTIVE]
ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'>
<<WLS Kernel>> <> <> <1426771159618>
<BEA-090870> <The realm "myrealm" failed to be loaded:
weblogic.security.service.SecurityServiceException:
com.bea.common.engine.ServiceInitializationException:
weblogic.security.spi.ProviderInitializationException: A failure occurred
attempting to load LDIF for provider Authorizer from file
/home/oracle/Oracle/Middleware/wlserver/server/lib/XACMLAuthorizerInit.ldift..
At the first glance the problem is related to RDBMS security store. The possible solution could be executing rdbms_security_store_oracle.sql script which is placed under $WL_HOME/server/lib directory. But not in my case, as I did not use RDBMS security store.
The solution of my problem was much easier. You just need to check your /etc/hosts configuration file (in my case I’ve used OL6 OS) and ensure that you added the line with appropriate machine IP address and hostname as in example below:
[root@ol6u5
~]# cat /etc/hosts
192.168.56.199 ol6u5 ol6u5.ru.doyensys.com
After this action Admin Server was started successfully.
Be happy with your WebLogic Server Configuration!

No comments: